Unexpected error occurred while communicating with Administration Service

Problem 

I created a web application with one site collection (http://Server/sites/FastDemo) and enabled the SSA’s(Connector and Query) for fast search for this particular web application.

When I search with my keyword I was able to see the search results but when I tried to click on the fast keyword settings to configure the key words I got the below error:

search

When we work on Fast Search, we might encounter this error in many places.

Solution

When I checked the “FASTSearchAdministrators” local admin group, I was able to see my application pool account configured for my web application. But I did not see any group name called “FASTSearchKeywordAdministrators” in the local admin group.

To fix this issue I just created a new group with name “FASTSearchKeywordAdministrators” in local admin groups manually and added the service account configured in application pool for my web application.

As per my understanding this group should be added as a part of the FAST Search installation automatically. If not we have to create it manually.

Now the below sections are started working

  • Fast Search Keywords
  • Fast Search Site Promotion and Demotion
  • Fast Search User Context

I just started working on Fast Search and new to this. If the above mentioned solution is not the right one to fix this issue please let me know.

Advertisements

About Joseph Velliah
As a SharePoint Developer my professional interests tend to be technical and SharePoint focused. I run a blog at "SP RIDER" where you can expect to read HOW TOs and scenarios that I run into during my day to day job. I hope my posts will give back a little to the community that is helped me.

Comments are closed.

%d bloggers like this: